Skip to main content
print this page

Sensitive JDBC datasource connection details could appear in CloudWatch Logs

· 3 min read
Patch Available
Patch Available
This bug has a patch available for affected versions

Sensitive JDBC datasource connection details could appear in CloudWatch Logs

Affected Versions: 2.7 3.0.3 3.1 3.2 3.3

Fix Version: 3.3

Patch: A fix is available for the affected release lines above. Contact Amorphic support and schedule an upgrade so your environment receives an Amorphic build that includes this fix.

print this page
print this page

JDBC bulkdataload dataflows issues

· 3 min read
Fix Available
Fix Available
This bug has been fixed

JDBC Bulkdataload Dataflows Issues

Affected Versions: 2.7 3.0 3.0.3 3.0.6

Fix Version: 3.1

This report covers two related issues affecting JDBC bulkdataload dataflows:

  • Individual source table reload not working for full load dataflows
  • Endpoint testing failing immediately without retry on timeout.
print this page
print this page

Data loss when uploading files with the same name from different folders

· 3 min read
Fix Available
Fix Available
This bug has been fixed

Files with identical names from different folders may not upload correctly, causing some of your data to be lost during S3 ingestion.

Affected Versions: 2.7 3.0

Fix Version: 3.1

Root cause(s)

When you upload files with the same name from different folders in your S3 bucket, Amorphic doesn't always process all of them correctly.

print this page
print this page

Datalab Studio creation failure

· 2 min read
Fix Available
Fix Available
This bug has been fixed

Datalab post custom R image changes fail due to corrupted backend image corresponding to the required R configurations

Affected Versions: 3.0 3.0.3 3.0.6

Fix Version: 3.1

print this page
print this page

Deleted User metadata remains in role managers list

· 2 min read
Fix Available
Fix Available
This bug has been fixed

Upon deletion of a user from Amorphic, its associated metadata is also removed. But metadata pertaining to this said user is actually retained in the Role Managers list in the Roles metadata in the backend tables.

Affected Versions: 2.7 3.0 3.0.3 3.0.6

Fix Version: 3.0.6

print this page

Glossary term update failure

· 2 min read
Fix Available
Fix Available
This bug has been fixed

Glossary term metadata still pertains in backend table even after parent dataset was deleted

Affected Versions: 2.7 3.0 3.0.3 3.0.6

Fix Version: 3.0.6